If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

SHO Collision sensor problems

Post Reply
The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

SHO Collision sensor problems

Post by The Bone » Sat Feb 27, 2016 8:38 am

I got in my 21 SHO the other day and the collision sensor said it was blocked. I removed the cover and It had some dust on it so I wiped it off. Still same thing. So I unhooked the battery to reset the computer and next morning the system worked just fine. During the day the system said malfunction. Crap!!! It's hooked to the cruise control so that doesn't work ether. If I go to the dealer it will cost me $100 so I ask for help here first.


apial
Regular Member
Posts: 49
Joined: Wed Jan 20, 2016 11:34 pm
Location: Wharton NJ
Contact:

Re: SHO Collision sensor problems

Post by apial » Sun Mar 06, 2016 8:14 am

Are you referring to the "YAW" sensor and how do you know it was "blocked".

Do you have DTCs ?
Sascha
Ford-Retrofit.com
Contact me for any kind of retrofits e.G to add NAV to your MFT(SYNC2)

The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

Re: SHO Collision sensor problems

Post by The Bone » Mon Mar 07, 2016 9:03 am

The info screen says the ACC radar is blocked. I took the cover off on the lower grill and there was nothing there. It doesnt work if its raining hard but i get this on a sunny day. Taking it to the dealer today.

apial
Regular Member
Posts: 49
Joined: Wed Jan 20, 2016 11:34 pm
Location: Wharton NJ
Contact:

Re: SHO Collision sensor problems

Post by apial » Wed Mar 09, 2016 11:00 pm

Let us know. Malfunction message should create a DTC so it should be easy to fix.

Maybe just need to be re-calibrated. Or the whole module isn't responding, but you would also be able to see this in the IPC module
Sascha
Ford-Retrofit.com
Contact me for any kind of retrofits e.G to add NAV to your MFT(SYNC2)

The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

Re: SHO Collision sensor problems

Post by The Bone » Thu Mar 10, 2016 8:14 am

Took it to the dealer and they have to replace the cruise control module.

apial
Regular Member
Posts: 49
Joined: Wed Jan 20, 2016 11:34 pm
Location: Wharton NJ
Contact:

Re: SHO Collision sensor problems

Post by apial » Thu Mar 10, 2016 10:08 pm

I hope you have extended warranty. I saw them breaking before, costs around 800$ just the part :evil:
Sascha
Ford-Retrofit.com
Contact me for any kind of retrofits e.G to add NAV to your MFT(SYNC2)

The Bone
Regular Member
Posts: 390
Joined: Fri Jan 17, 2014 11:41 am

Re: SHO Collision sensor problems

Post by The Bone » Mon Mar 14, 2016 2:06 pm

That's incredible news about them braking. Must be a crappy part. I will ask them if they can disable it after the part comes in. I wish i had known how much I don't like the ACC system. I would much rather have the PP instead. couldn't have both at the time I got mine. I do have the extended warranty. It's about up :(

Post Reply