If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2013 Interceptor horn not working

Post Reply
CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

2013 Interceptor horn not working

Post by CVOGLER » Sun Mar 12, 2017 6:06 pm

My new 2013 interceptor horn doesn't work. My wife has it right now so I can't check if it has the fuse. Why would the dept remove the horn? It seems odd to me but I'm new to owning old cop cars.


CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Sun Mar 19, 2017 9:18 am

Well it has the horn and fuses now it's chasing the wiring does anybody have a suggestion of where I should start looking?

trife86
Regular Member
Posts: 19
Joined: Wed Mar 01, 2017 5:08 pm
Vehicle: 2013 PI Sedan

Re: 2013 Interceptor horn not working

Post by trife86 » Sun Mar 19, 2017 4:28 pm

Trace the wire all the way from steering wheel to the fuse, alot of depts tap the horn wiring to run the siren as a option.

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Sun Mar 19, 2017 6:38 pm

Ok so you happen to know what the color of the wires are?

jmr061
Regular Member
Posts: 689
Joined: Thu May 23, 2013 3:48 pm

Re: 2013 Interceptor horn not working

Post by jmr061 » Mon Mar 20, 2017 10:57 am

Jason
2016 Edge Sport
www.FordPIMods.com
I was looking over your site and wanted to say, thank you for all the info. - CrownedKing 11/2015

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Mon Mar 20, 2017 8:18 pm

Ok thanks

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Wed Mar 29, 2017 1:45 am

Ok forgive me for another stupid question but where is the center stack for the wiring bundle on the car? I am used to working on cars built in the 1960's not this new. Thanks again for any help.

Voltaren101
New Member
Posts: 1
Joined: Wed Sep 13, 2017 1:37 am
Vehicle: 2013 Ford police interceptor

Re: 2013 Interceptor horn not working

Post by Voltaren101 » Wed Sep 13, 2017 1:40 am

Have you fixed your horn yet? If not I'll walk you thru it step by step. Will take 5 minutes to fix

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Fri Sep 29, 2017 1:44 am

yeah I did get it fixed.

robreg
New Member
Posts: 1
Joined: Tue Oct 17, 2017 2:46 pm
Vehicle: 2013 Taurus PPV

Re: 2013 Interceptor horn not working

Post by robreg » Tue Oct 17, 2017 2:49 pm

I have the same thing no horn, could you walk me thru it.
Thanks

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Sat Nov 04, 2017 10:48 am

I went to the dealer near by and they fixed it. My wife needed it working for a trip otherwise I would have chased it myself. If I remember right the dealer showed me it was cut right by the steering column. I'm sorry I can't be of more help

PFFCO
Regular Member
Posts: 23
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI

Re: 2013 Interceptor horn not working

Post by PFFCO » Mon Dec 10, 2018 4:41 pm

SO, where is the physical horn? I took a quick look everywhere but can't find the horn. I have the same issue. My last car had an electronic siren/horn and the horn wire was the trigger. So far I checked the fuse and it appears to be good, but I don't hear any relay clicking either. Still looking.

In the process of programming the remote keyless entry fobs, I heard the horn honk, so I know I have a working horn. I'm thinking its either the steering wheel switch, or some tie in to the siren unit that is no longer with the car.

CVOGLER
Regular Member
Posts: 15
Joined: Mon Feb 20, 2017 10:53 pm
Vehicle: 2013 ford interceptor

Re: 2013 Interceptor horn not working

Post by CVOGLER » Mon Dec 17, 2018 10:34 am

The horn is mounted near the front fender on the driver side below the airbox or at least near that.

PFFCO
Regular Member
Posts: 23
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI

Re: 2013 Interceptor horn not working

Post by PFFCO » Tue Dec 18, 2018 7:32 am

I went looking and found it. I think there is a loop that is cut somewhere so that the siren/air horn worked with the horn button. The Modifiers guide shows where to look for this loop.

http://www.policeinterceptor.com/pdf/20 ... 0Guide.pdf

Post Reply