If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

2014 PI, Fixed the horn!!

Post Reply
PFFCO
Regular Member
Posts: 55
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI AWD 3.5l Twin Turbo

2014 PI, Fixed the horn!!

Post by PFFCO » Sat Dec 29, 2018 5:09 pm

I finally decided to remove the center console which was pretty beat up and not functional the way I wanted it.

After all that, I was able to remove the center panel where the 12 volt outlets are. The console actually hid them and you couldn't use them as well as I liked.

I dug a bit deeper and found the ground wire that is documented in the 2014 Modifier guide. Sure enough, the wire was cut. One wirenut later, I now have a working horn!
Attachments
IMG_1353.jpg
IMG_1353.jpg (86.02 KiB) Viewed 1050 times


eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Sun Sep 15, 2019 2:46 pm

Center console you mean the radio console?
Last edited by eguterac on Sun Sep 15, 2019 3:43 pm, edited 1 time in total.

PFFCO
Regular Member
Posts: 55
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI AWD 3.5l Twin Turbo

Re: 2014 PI, Fixed the horn!!

Post by PFFCO » Sun Sep 15, 2019 2:53 pm

Yes. Good catch. I had removed the radio console where the cig outlets are and dug for the wire. Spliced it and horn was back working.

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Sun Sep 15, 2019 3:46 pm

I have the same problem no horn. Oh so its going to be located somewhere up in the radio section. Cool I'll have to check it out thanks!

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Thu Sep 19, 2019 9:29 am

PFFCO wrote:
Sat Dec 29, 2018 5:09 pm
I finally decided to remove the center console which was pretty beat up and not functional the way I wanted it.

After all that, I was able to remove the center panel where the 12 volt outlets are. The console actually hid them and you couldn't use them as well as I liked.

I dug a bit deeper and found the ground wire that is documented in the 2014 Modifier guide. Sure enough, the wire was cut. One wirenut later, I now have a working horn!
Could this be the cable to the horn? Looks very similar to yours.
Attachments
IMG_20190919_070508.jpg
IMG_20190919_070508.jpg (219.69 KiB) Viewed 525 times

andynumbers
Regular Member
Posts: 21
Joined: Mon Aug 05, 2019 3:28 pm
Vehicle: 2015 FPIS 3.7 AWD

Re: 2014 PI, Fixed the horn!!

Post by andynumbers » Thu Sep 19, 2019 9:36 am

Yeah that's it. You'll notice that it's the same wire color, just it's been cut. Splice those two wires together and the horn should work.

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Thu Sep 19, 2019 9:50 am

andynumbers wrote:
Thu Sep 19, 2019 9:36 am
Yeah that's it. You'll notice that it's the same wire color, just it's been cut. Splice those two wires together and the horn should work.
Awesome!!! I really need to do some clean up.

Any idea what that large grey with red insert unplugged is for?
Attachments
IMG_20190919_070429.jpg
IMG_20190919_070429.jpg (325.1 KiB) Viewed 523 times

PFFCO
Regular Member
Posts: 55
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI AWD 3.5l Twin Turbo

Re: 2014 PI, Fixed the horn!!

Post by PFFCO » Thu Sep 19, 2019 9:54 am

the large gray connector I think is the 6 pin cable that gives you dedicated 12 volts and ground there. There is also a 14 pin connector i there that goes to wiring for lights. I traced mine out to the lights on the sides of the car and the front. From the factory. You do have some other stuff in there that must have been added by the upfitter or police department. So nice to have a working horn...

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Thu Sep 19, 2019 9:58 am

Well everything works on my center console so I won't touch that. But I'm glad I found the horn wire. Now I just need to find a new or a used center console to replace this one. Thanks for the info!

PFFCO
Regular Member
Posts: 55
Joined: Sun Dec 09, 2018 8:21 am
Vehicle: 2014 PI AWD 3.5l Twin Turbo

Re: 2014 PI, Fixed the horn!!

Post by PFFCO » Thu Sep 19, 2019 10:02 am

I bought this center console off of Ebay.

Bolted right to my existing metal plate. I'm happy with it. 2 drink holders, arm rest and storage.

https://www.ebay.com/itm/Deluxe-Center- ... 2749.l2649

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Thu Sep 19, 2019 10:20 am

Oh I mean the radio one that has the 12v plugs. But yes I do need a tunnel plate to mount a Havis console. In my Crown Victoria I had my CB Radio and Scanner. I want the same set up.
Attachments
Screenshot_20190816-181707.png
Screenshot_20190816-181707.png (714.04 KiB) Viewed 519 times

eguterac
Regular Member
Posts: 24
Joined: Sun Sep 15, 2019 1:33 pm
Vehicle: 14 Ford Taurus Police

Re: 2014 PI, Fixed the horn!!

Post by eguterac » Tue Sep 24, 2019 6:09 pm

andynumbers wrote:
Thu Sep 19, 2019 9:36 am
Yeah that's it. You'll notice that it's the same wire color, just it's been cut. Splice those two wires together and the horn should work.
It worked! Thanks for the info.

Post Reply