If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

My engine just went

Post Reply
13_3.5_turbo_fpis
Regular Member
Posts: 10
Joined: Fri Jan 04, 2019 2:39 am
Vehicle: 2013 fpis 3.5 L ecoboost

My engine just went

Post by 13_3.5_turbo_fpis » Thu Apr 04, 2019 10:37 am

I have a 2013 Ford Taurus 3.5 turbo and I'm at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons


TerryY
Regular Member
Posts: 47
Joined: Sat Sep 24, 2016 9:12 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by TerryY » Thu Apr 04, 2019 12:15 pm

OR a turbo seal

Jake_Blues
Regular Member
Posts: 79
Joined: Sun Jan 27, 2019 8:25 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by Jake_Blues » Thu Apr 04, 2019 5:32 pm

bummer dude - sorry to hear that.

if it's going to be a new/rebuilt engine it's almost worth it to get a another 2013/2014 at auction/Copart to do a transplant.

13_3.5_turbo_fpis
Regular Member
Posts: 10
Joined: Fri Jan 04, 2019 2:39 am
Vehicle: 2013 fpis 3.5 L ecoboost

Re: My engine just went

Post by 13_3.5_turbo_fpis » Fri Apr 05, 2019 8:06 am

They are replacing the engine valve seal , only going to cost me $300

Jake_Blues
Regular Member
Posts: 79
Joined: Sun Jan 27, 2019 8:25 pm
Vehicle: 2013 Police Interceptor Sedan

Re: My engine just went

Post by Jake_Blues » Fri Apr 05, 2019 1:46 pm

wow! lucky that!

mymangochutney
Regular Member
Posts: 122
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Re: My engine just went

Post by mymangochutney » Mon Apr 08, 2019 3:00 pm

13_3.5_turbo_fpis wrote:
Thu Apr 04, 2019 10:37 am
I have a 2013 Ford Taurus 3.5 turbo and I’m at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons
isn't a used engine $600?

GCM
New Member
Posts: 3
Joined: Mon Mar 25, 2019 2:22 am
Vehicle: 2014 Police Interceptor Sedan

Re: My engine just went

Post by GCM » Mon Apr 22, 2019 5:35 pm

mymangochutney wrote:
Mon Apr 08, 2019 3:00 pm
isn't a used engine $600?
What’s the source of the $600 engine? I’d like a spare 3.7l to put in when I decide to replace the water pump. Maybe rotate them every 100K.

mymangochutney
Regular Member
Posts: 122
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Re: My engine just went

Post by mymangochutney » Tue Apr 23, 2019 1:44 pm

GCM wrote:
Mon Apr 22, 2019 5:35 pm
mymangochutney wrote:
Mon Apr 08, 2019 3:00 pm
isn't a used engine $600?
What’s the source of the $600 engine? I’d like a spare 3.7l to put in when I decide to replace the water pump. Maybe rotate them every 100K.
car-part.com

https://i.imgur.com/W8DcwQm.png

Post Reply