Page 1 of 1

My engine just went

Posted: Thu Apr 04, 2019 10:37 am
by 13_3.5_turbo_fpis
I have a 2013 Ford Taurus 3.5 turbo and I'm at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons

Re: My engine just went

Posted: Thu Apr 04, 2019 12:15 pm
by TerryY
OR a turbo seal

Re: My engine just went

Posted: Thu Apr 04, 2019 5:32 pm
by Jake_Blues
bummer dude - sorry to hear that.

if it's going to be a new/rebuilt engine it's almost worth it to get a another 2013/2014 at auction/Copart to do a transplant.

Re: My engine just went

Posted: Fri Apr 05, 2019 8:06 am
by 13_3.5_turbo_fpis
They are replacing the engine valve seal , only going to cost me $300

Re: My engine just went

Posted: Fri Apr 05, 2019 1:46 pm
by Jake_Blues
wow! lucky that!

Re: My engine just went

Posted: Mon Apr 08, 2019 3:00 pm
by mymangochutney
13_3.5_turbo_fpis wrote:
Thu Apr 04, 2019 10:37 am
I have a 2013 Ford Taurus 3.5 turbo and I’m at 122,000 miles , engine was burning oil, now I have to get the engine rebuilt, has to be bad engine valves or pistons
isn't a used engine $600?

Re: My engine just went

Posted: Mon Apr 22, 2019 5:35 pm
by GCM
mymangochutney wrote:
Mon Apr 08, 2019 3:00 pm
isn't a used engine $600?
What’s the source of the $600 engine? I’d like a spare 3.7l to put in when I decide to replace the water pump. Maybe rotate them every 100K.

Re: My engine just went

Posted: Tue Apr 23, 2019 1:44 pm
by mymangochutney
GCM wrote:
Mon Apr 22, 2019 5:35 pm
mymangochutney wrote:
Mon Apr 08, 2019 3:00 pm
isn't a used engine $600?
What’s the source of the $600 engine? I’d like a spare 3.7l to put in when I decide to replace the water pump. Maybe rotate them every 100K.
car-part.com

https://i.imgur.com/W8DcwQm.png