Page 1 of 1

Advance trac + ABS warning light

Posted: Sun Apr 21, 2019 11:50 pm
by ssenter
I picked up a 2015 AWD 3.7 PI in Salt Lake City a month ago. About 1/2 way home to Klamath Falls, OR I got the combined "service Advance trac + ABS warning light" while driving in some slushy/rainy Interstate 80 conditions. I had it scanned by a local NAPA shop when I got the trans fluid, coolant and oil/filter changed a 3 weeks ago. 89,000 miles. They cleared the code, said it was an "old code". That cleared the warning lights until I took it through a car wash the other day. Not sure if its related, but the warning lights came up after I left the car wash. I'm suspecting an ABS wheel sensor/wiring. Any other thoughts? I'm taking it to a local mechanic who I trust to further repair if necessary, on Tuesday. Otherwise, I LOVE this car!

Thanks!
Scott

Re: Advance trac + ABS warning light

Posted: Mon Apr 22, 2019 9:02 pm
by kaznalon
Check your front wheel wells, look for any rubbing from the wheels while turning. I had this happen on mine due to the front tire wearing through the wheel well when turning too sharply, ended up rubbing through the speed sensor wire...quick solder and heat shrink job and all good to go. That's what my issue was at least

Re: Advance trac + ABS warning light

Posted: Mon Apr 22, 2019 11:55 pm
by ssenter
This might be an answer to my problem. I noticed when the temperature above 70* I get a distinct rubbing when turning the steering wheel! I can feel it through the steering wheel. Thanks for the reply!