If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Low oil pressure 2004 Taurus

Post Reply
Revken
New Member
Posts: 3
Joined: Sun Aug 27, 2017 6:23 am
Vehicle: 2004 Ford Taurus SE

Low oil pressure 2004 Taurus

Post by Revken » Sun Aug 27, 2017 6:42 am

Hello, I'm having a low oil pressure message that seems to be stopping the car from starting.

Background: I acquired the car 6months ago and it has always started fine. It needed the timing chain cover/oil pan gasket/ heater core replacement which I completed starting last Monday and finished last night (Saturday). I picked at it while having other things come up. I followed the YouTube videos from fordteckmakuloco. Everything went well then I added coolant and 4 quarts of mobile 1 5w20 oil and it started up. It was still jacked up on the passenger side so I could leave the tire off and check for leaks. I turned it off and on 2-3 times to check things and add coolant then it stumbled and stalled on it's own while it was idleing. I went to restart it and it wouldn't. Had a "low oil pressure" message on the dash. I removed the negative battery cable, lowered the car to level and the oil was barely on the dipstick. Added a quart, reconnected the battery but still no start. Still low oil message. Disconnected battery again and waited a good 5 min then tried again, but before I tried to start I turned the key to on and the low oil pressure message was still in the dash and no start.

It turns over fine. No security light, no other warning lights. I'm going to put my scanner on it today and see what's there and wipe it to see if it will work, but other than that I'm not sure how to proceed. Seems it could be the oil pressure sensor or the oil pump? I didn't touch the pump or screen when I had the pan down, but it looked fine. Definitely not plugged. Thoughts?


Revken
New Member
Posts: 3
Joined: Sun Aug 27, 2017 6:23 am
Vehicle: 2004 Ford Taurus SE

Re: Low oil pressure 2004 Taurus

Post by Revken » Sun Aug 27, 2017 3:48 pm

Update: used code reader and no codes. Low oil pressure still showing even before I cranked it. Turns over but no start.

Revken
New Member
Posts: 3
Joined: Sun Aug 27, 2017 6:23 am
Vehicle: 2004 Ford Taurus SE

Re: Low oil pressure 2004 Taurus

Post by Revken » Fri Sep 01, 2017 5:43 pm

ok, well it turned out I was just out of gas. :oops: The Low Oil Pressure message had me so distracted that I missed the obvious. Glad I didn't start taking things apart! Here's to my first contribution to the community (Cheers!)

Post Reply