If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Hello! New 2011 SHO owner with a big problem.

Post Reply
Reddog6596
New Member
Posts: 2
Joined: Sun Mar 11, 2018 9:51 pm
Vehicle: 2011 Taurus SHO

Hello! New 2011 SHO owner with a big problem.

Post by Reddog6596 » Sun Mar 11, 2018 9:58 pm

Hi everyone,

Just purchased a 2011 SHO with 84 k on it. Sadly I must report within 250 miles of purchase it went into limp mode and left me stranded roadside. Rough idle, no throttle response/power, stiff brake pedal. Check engine light is on as well as wrench icon. I suspect the Throttle body went south. Its been towed to the local ford dealer. Hopefully nothing major.

Other than that, I love the car. When it was running anyways. Great power and Fully loaded. Can't wait to get it back.

I've owned a 2007 Montego for 3 or 4 years and 80k trouble free miles. Hopefully the SHO will be the same once this is resolved.

Once it gets fixed ill be doing some tasteful mods. Nothing major.

If anyone has other ideas as to the problem, please post up.

Other than that, nice to be here.

Steve


mope
Regular Member
Posts: 120
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Hello! New 2011 SHO owner with a big problem.

Post by mope » Tue Mar 13, 2018 2:51 pm

I don't know about the TB diagnoses, but crazier things have happened.

Report back when you find out what happened!

Reddog6596
New Member
Posts: 2
Joined: Sun Mar 11, 2018 9:51 pm
Vehicle: 2011 Taurus SHO

Re: Hello! New 2011 SHO owner with a big problem.

Post by Reddog6596 » Tue Mar 13, 2018 3:17 pm

Well, Ford just called.

Electronic throttle body is shot. They cant get it to act up but that's what the code was for. Then they told me it would be 720$ for a new one. I lauged. Ordered one off eBay used to get me by for now for 50$ shipped.

Just as an FYI a reman runs 100$ roughly and I've found brand new one for $200 or less.

They did however find a leak on the pass front axle seal so they are going to make sure its just the outer seal and replace it.

mope
Regular Member
Posts: 120
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Hello! New 2011 SHO owner with a big problem.

Post by mope » Wed Mar 14, 2018 3:28 pm

That's great news! I haven't heard of any other TB's going out, but if you can get out of a modern repair for under $50 (and whatever their diagnostic fee was), you've just had a helluva good day!.

Post Reply