If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Back up camera intermittently turns off 2011 Taurus

Post Reply
Jaxguy67
New Member
Posts: 2
Joined: Thu Aug 23, 2018 8:25 pm
Vehicle: 2011 Ford Taurus Limited

Back up camera intermittently turns off 2011 Taurus

Post by Jaxguy67 » Thu Aug 23, 2018 8:35 pm

My 2011 Taurus Limited back up camera works intermittently. It will display when I engage reverse but then after a few seconds it goes blank. Not a blue screen or any error message. Just blank. Then sometimes it pops back on. It does this 50/50. Took it to Ford and $49 later they said “you need a new camera, that’ll be $800 please”. Well I politely said no thanks. If the camera was bad wouldn’t it not work 100% of the time? How hard to replace? I LOVE my backup camera y’all.help!


mope
Regular Member
Posts: 135
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Back up camera intermittently turns off 2011 Taurus

Post by mope » Fri Aug 24, 2018 6:53 am

countless threads on your issue.......more than makes sense to recap here. there was a bad group of cameras/apims/both back then.

just google search for 2010 taurus camera not working or intermittent and youll see them. iirc the answer is to get a new camera, but youd be nuts to spend dealership $ to do that. either self install or live without on a car that old.

Jaxguy67
New Member
Posts: 2
Joined: Thu Aug 23, 2018 8:25 pm
Vehicle: 2011 Ford Taurus Limited

Re: Back up camera intermittently turns off 2011 Taurus

Post by Jaxguy67 » Sun Aug 26, 2018 9:53 pm

Thanks for the info. Decided to buy OEM camera and install myself. What could go wrong? Lol. Thanks.

GhostRider
Regular Member
Posts: 718
Joined: Wed Oct 10, 2012 7:34 am
Location: Ohio
Vehicle: 2013 Ford Taurus Limited

Re: Back up camera intermittently turns off 2011 Taurus

Post by GhostRider » Mon Aug 27, 2018 3:28 pm

My camera just started acting up
2013 Ford Taurus Limited FWD (301A Package)

Post Reply