If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Early water pump leak? 2015 Taurus

Post Reply
mymangochutney
Regular Member
Posts: 43
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Early water pump leak? 2015 Taurus

Post by mymangochutney » Mon Oct 01, 2018 6:58 am

Hi, I have a 2015 and noticed the coolant tank was low when I bought the car (idiot move!!) and got a flush and pressure test done at the dealer.


The system passed the pressure test when they tried but could also mean only 1 seal failed or something. The level after 2 months has dropped below the min line today.

I tried to see for any leaks under the car but couldn't find that much.
Attachments
quNrAnv.jpg
quNrAnv.jpg (122.98 KiB) Viewed 135 times
Usl32NM.jpg
Usl32NM.jpg (126.32 KiB) Viewed 135 times
3meIqoy.jpg
3meIqoy.jpg (199.22 KiB) Viewed 135 times
w6iKoWR.jpg
w6iKoWR.jpg (159.72 KiB) Viewed 135 times


mope
Regular Member
Posts: 130
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Early water pump leak?

Post by mope » Mon Oct 01, 2018 8:56 am

I don't see any initial reason to be worried.

Check your weep hole. That's where your first sign will be.
If nothing and you're still worried, check your oil cap or change the oil and look for chocolate milk/peanut butter which would indicate coolant contamination.

mymangochutney
Regular Member
Posts: 43
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Re: Early water pump leak?

Post by mymangochutney » Mon Oct 01, 2018 9:39 am

Oil cap is empty, I tried finding any weep holes visible from bay but didn't see any, and don't have a lift so can't see from bottom.

The loss is so slow (for now)I think it's being evaporated so it's not even really mixing?

mope
Regular Member
Posts: 130
Joined: Mon Oct 03, 2016 4:11 pm
Vehicle: 2013 Interceptor

Re: Early water pump leak?

Post by mope » Mon Oct 01, 2018 12:00 pm

yea, evap or a small drip at a connection somewhere. like i said, i dont see a reason to be concerned from what youre seeing.

look for youtube vids on the weep hole. you should be able to see it without a lift.

mymangochutney
Regular Member
Posts: 43
Joined: Thu Jun 14, 2018 9:50 pm
Vehicle: Taurus FPIS 2013

Re: Early water pump leak?

Post by mymangochutney » Mon Oct 01, 2018 3:24 pm

mope wrote:
Mon Oct 01, 2018 12:00 pm
yea, evap or a small drip at a connection somewhere. like i said, i dont see a reason to be concerned from what youre seeing.

look for youtube vids on the weep hole. you should be able to see it without a lift.
Does the excess gunk mean evap?

Post Reply