If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Charging System, Electrical/Power Problem? *Novice*

Post Reply
itsrocky94
New Member
Posts: 1
Joined: Mon Nov 05, 2018 1:28 pm
Vehicle: 2005 Ford Taurus SE

Charging System, Electrical/Power Problem? *Novice*

Post by itsrocky94 » Mon Nov 05, 2018 2:02 pm

Hey. I looked around but couldn't find a thread exactly what I was looking for. My grandmother owns a 05 Taurus SE and I know nothing about cars but 2 days ago the "Check Charging System" came on the info dash. I didn't think much of it and went to work. Coming home the car started but the airbag light came on, the dash lights were very dim and the headlights very dim as well. Also the windows wouldn't work. We recently bought a new starter, battery (88% right now) and alternator about 2 months ago. I searched online and found out that most likely my problem was the alternator. So I looked online, found out how to take it out and did so and took it to the store where I had purchased it to swap it out. They tested it and said it was defected. I put it in and the car started right up and everything seemed great until I left to go to work about an hour later. The "Check Charging System" on the info panel has come back, along with the yellow battery light. We have been having problems using windows for awhile so I think it may be an electrical issue but I have no clue. I checked fuse 26, the battery is fine. So does anyone know what could maybe be the issue or if this happens alot?


Post Reply