If you shop at Amazon.com (for anything), use this link to support FordTaurus.net!

Advance trac + ABS warning light

Post Reply
ssenter
New Member
Posts: 2
Joined: Sun Apr 21, 2019 11:39 pm
Vehicle: 2015 Police Interceptor 3.7 AW

Advance trac + ABS warning light

Post by ssenter » Sun Apr 21, 2019 11:50 pm

I picked up a 2015 AWD 3.7 PI in Salt Lake City a month ago. About 1/2 way home to Klamath Falls, OR I got the combined "service Advance trac + ABS warning light" while driving in some slushy/rainy Interstate 80 conditions. I had it scanned by a local NAPA shop when I got the trans fluid, coolant and oil/filter changed a 3 weeks ago. 89,000 miles. They cleared the code, said it was an "old code". That cleared the warning lights until I took it through a car wash the other day. Not sure if its related, but the warning lights came up after I left the car wash. I'm suspecting an ABS wheel sensor/wiring. Any other thoughts? I'm taking it to a local mechanic who I trust to further repair if necessary, on Tuesday. Otherwise, I LOVE this car!

Thanks!
Scott
Attachments
Front.jpg
Front.jpg (121.47 KiB) Viewed 420 times


kaznalon
New Member
Posts: 3
Joined: Mon Apr 17, 2017 7:04 pm
Vehicle: 2013 PI Sedan

Re: Advance trac + ABS warning light

Post by kaznalon » Mon Apr 22, 2019 9:02 pm

Check your front wheel wells, look for any rubbing from the wheels while turning. I had this happen on mine due to the front tire wearing through the wheel well when turning too sharply, ended up rubbing through the speed sensor wire...quick solder and heat shrink job and all good to go. That's what my issue was at least

ssenter
New Member
Posts: 2
Joined: Sun Apr 21, 2019 11:39 pm
Vehicle: 2015 Police Interceptor 3.7 AW

Re: Advance trac + ABS warning light

Post by ssenter » Mon Apr 22, 2019 11:55 pm

This might be an answer to my problem. I noticed when the temperature above 70* I get a distinct rubbing when turning the steering wheel! I can feel it through the steering wheel. Thanks for the reply!

Post Reply